RIPv2 (Routing Information Protocol) – Basics Part 2

Out of the many dynamic routing protocols RIP or RIPv2 is probably the most basic and easy to setup. The biggest difference between RIP and RIPv2 is that RIP does not support VLSM (Variable Length Subnet Masking) and RIPv2 does. For the modern network we need to use at least RIPv2 for proper routing.

Things to keep in mind:

  • To use RIPv2 we need to enable it:
SEA#config terminal
Example(config)#router rip
Example(config-router)#version 2
Example(config-router)#do show run | b rip
router rip
version 2
  • By default when RIPv2 is enabled RIP will advertise routes based on the network bits and the class that those bits belong to (A, B, or C). In order to get rid of the classful advertisement and make RIPv2 advertise individual subnets as a classless protocol you will need to turn auto-summary off:
Example#config terminal
Example(config)#router rip
Example(config-router)#no auto
Example(config-router)#no auto-summary

Most common show/debug commands:

show ip route
show ip protocols
debug ip rip

Example and Explanation of a basic RIPv2 config

ROUTER 1 Config:

interface Loopback1 (Virtual interface created for testing purposes)
ip address 192.168.254.1 255.255.255.0
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.252
!
router rip (This enables RIP)
version 2 (This sets RIP to use version 2 features)
network 192.168.1.0 (Network which I want to advertise using using RIP)
network 192.168.254.0
no auto-summary (Disables classful advertisements, with auto-summary turned off RIP will advertise the subnet mask in its updates)

ROUTER 2 Config:

interface Loopback1
ip address 192.168.255.1 255.255.255.0
!
interface Ethernet0/1
ip address 192.168.1.2 255.255.255.252
!
router rip
version 2
network 192.168.1.0
network 192.168.255.0
no auto-summary

Enabling the following configs on two routers will start the process of advertising RIPv2 updates, advertise the desired routes, and provide the ability for end-to-end communication.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s